You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by opsec (Apr 1st 2012, 7:44pm)

2 719

by Wet_Boots

(Apr 2nd 2012, 9:08am)

by jack z (Apr 8th 2012, 10:35am)

1 606

by mrfixit

(Apr 8th 2012, 2:37pm)

by mack (Apr 18th 2012, 8:30pm)

2 747

by mack

(Apr 19th 2012, 12:54pm)

by whitty (Apr 20th 2012, 8:09am)

10 978

by GatorGuy

(Apr 23rd 2012, 8:45am)

by SpritzCan (Apr 21st 2012, 8:33pm)

2 329

by GatorGuy

(Apr 23rd 2012, 8:47am)

by crashxx (Apr 28th 2012, 12:16pm)

4 1,144

by crashxx

(May 1st 2012, 9:15am)

by Stu1986 (May 5th 2012, 11:44pm)

3 521

by mrfixit

(May 6th 2012, 1:23pm)

by odiaz1 (May 10th 2012, 10:18am)

1 514

by Wet_Boots

(May 10th 2012, 10:26am)

by stktrader (May 20th 2012, 5:55pm)

4 553

by Wet_Boots

(May 21st 2012, 7:02am)

by Cherrybark (May 20th 2012, 6:22pm)

2 501

by GatorGuy

(May 21st 2012, 9:04am)

Show

Statistics:

486 Threads - 1,840 Posts (average 0.36 Posts per Day)