You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Roger Stover (Jun 16th 2009, 11:09am)

4 334

by hi.todd

(Jun 19th 2009, 10:27pm)

by d leimer (Jun 14th 2009, 11:45pm)

2 498

by hi.todd

(Jun 19th 2009, 10:24pm)

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 288

by hi.todd

(Jun 19th 2009, 10:23pm)

by larbec7 (Jun 6th 2009, 5:07pm)

9 1,590

by Wet_Boots

(Jun 9th 2009, 12:52pm)

by killerj (May 25th 2009, 10:32am)

0 283

No reply

by Jeff Nobles (May 21st 2009, 9:40am)

3 705

by hi.todd

(May 22nd 2009, 8:19pm)

by gbreiten (May 19th 2009, 10:18am)

0 200

No reply

by kenball27 (May 1st 2009, 1:01pm)

3 2,700

by mrfixit

(May 10th 2009, 1:13pm)

by PSpatches (Apr 28th 2009, 10:31am)

1 380

by Candance

(May 9th 2009, 9:13pm)

by India (Mar 17th 2009, 7:07am)

5 735

by HooKooDooKu

(Mar 25th 2009, 10:16pm)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)