You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by rockypoint (Nov 26th 2012, 6:02pm)

2 636

by mrfixit

(Nov 26th 2012, 7:30pm)

by jwdawgs (Feb 26th 2007, 4:10pm)

11 637

by Tom

(Feb 28th 2007, 12:48pm)

by Jimy (Aug 30th 2011, 11:45am)

4 639

by chrisrlewis78

(Sep 4th 2011, 2:52pm)

by steve123 (Nov 22nd 2003, 8:10am)

1 639

by SprinklerGuy

(Nov 24th 2003, 5:42am)

by ksrmc (Aug 1st 2012, 3:27pm)

6 645

by Wet_Boots

(Aug 2nd 2012, 9:31am)

by fireman (Sep 15th 2006, 3:14pm)

8 645

by mrfixit

(Sep 19th 2006, 9:59am)

by ruchuck (May 29th 2013, 8:54am)

7 650

by mrfixit

(Jun 2nd 2013, 12:03am)

by nrwe (Jul 19th 2012, 1:57pm)

4 661

by mrfixit

(Jul 20th 2012, 3:06pm)

by lou40 (Nov 9th 2011, 4:15pm)

3 662

by Wet_Boots

(Nov 13th 2011, 8:15am)

by Brie (Feb 24th 2009, 11:42am)

2 663

by sanzen96

(Mar 21st 2009, 3:55pm)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)