You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Jlivengood (Oct 20th 2012, 2:01am)

3 532

by Wet_Boots

(Oct 20th 2012, 5:11pm)

by fireman (Sep 15th 2006, 3:14pm)

8 532

by mrfixit

(Sep 19th 2006, 9:59am)

by fatelvis00 (Aug 4th 2006, 2:58pm)

1 532

by mrfixit

(Aug 7th 2006, 1:26am)

by csnugg (Jun 26th 2006, 4:10pm)

0 532

No reply

by nrwe (Jul 19th 2012, 1:57pm)

4 533

by mrfixit

(Jul 20th 2012, 3:06pm)

by rockypoint (Nov 26th 2012, 6:02pm)

2 542

by mrfixit

(Nov 26th 2012, 7:30pm)

by Jimy (Aug 30th 2011, 11:45am)

4 548

by chrisrlewis78

(Sep 4th 2011, 2:52pm)

by rspfau (Jun 9th 2011, 6:12pm)

4 554

by Mitchgo

(Jun 9th 2011, 10:08pm)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 558

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by hudr0004 (Sep 12th 2011, 10:16am)

4 559

by hudr0004

(Oct 24th 2011, 8:38am)

Show

Statistics:

436 Threads - 1,648 Posts (average 0.36 Posts per Day)