You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by lschwart (May 2nd 2006, 3:53am)

3 315

by kevin burklund

(May 10th 2006, 12:18pm)

by kazemi (Sep 5th 2005, 11:57am)

3 289

by Wet_Boots

(Sep 5th 2005, 2:14pm)

by redlinr (Jun 9th 2005, 3:46am)

3 643

by Jazzer K

(Sep 2nd 2005, 6:14pm)

by binki3 (Aug 29th 2005, 10:33am)

3 302

by RidgeRun05

(Aug 30th 2005, 11:16am)

by Fapp (Feb 21st 2005, 10:11am)

3 552

by nestors

(Apr 7th 2005, 8:51am)

by mosida (Sep 29th 2004, 9:16am)

3 213

by nestors

(Oct 31st 2004, 1:27pm)

by jbbnet (Aug 19th 2004, 5:11pm)

3 145

by SamIV

(Aug 29th 2004, 5:43am)

by rickesco (Jul 28th 2004, 8:13am)

3 167

by aquamatic

(Jul 29th 2004, 10:36am)

by Rendaug (Jan 18th 2004, 12:31pm)

3 200

by Rendaug

(Feb 8th 2004, 10:37am)

by labert (Jan 3rd 2004, 6:11am)

3 756

by labert

(Jan 7th 2004, 2:15pm)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)