You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Shred Happy (Dec 21st 2011, 9:04am)

1 1,044

by Wet_Boots

(Dec 21st 2011, 12:54pm)

by pphilt (Oct 9th 2011, 9:55pm)

5 520

by JimmyTheGlove

(Oct 13th 2011, 3:24pm)

by patk (Sep 18th 2011, 2:17pm)

2 886

by patk

(Sep 18th 2011, 3:41pm)

by Jimy (Aug 30th 2011, 11:45am)

4 879

by chrisrlewis78

(Sep 4th 2011, 2:52pm)

by lbfalgi (Aug 30th 2011, 6:15pm)

1 1,531

by Central Irrigation

(Aug 30th 2011, 8:38pm)

by John199 (Aug 14th 2011, 3:57pm)

4 1,138

by hi.todd

(Aug 15th 2011, 7:29pm)

by Drski (Jul 29th 2011, 11:50am)

5 849

by Drski

(Aug 9th 2011, 11:04am)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 294

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by HHicks (Jul 22nd 2011, 4:57pm)

1 845

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by Mac54321 (Jul 13th 2011, 10:03am)

1 1,094

by Wet_Boots

(Jul 13th 2011, 11:30am)

Show

Statistics:

485 Threads - 1,829 Posts (average 0.36 Posts per Day)