You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by dimlach@peoplepc.com (Apr 22nd 2005, 7:51am)

2 519

by The Professor

(May 26th 2005, 9:53pm)

by Texas_Pete (May 1st 2005, 7:21pm)

1 318

by Wet_Boots

(May 2nd 2005, 2:02am)

by mosida (Sep 29th 2004, 9:16am)

3 224

by nestors

(Oct 31st 2004, 1:27pm)

by mugentuner (Aug 30th 2004, 12:30pm)

1 166

by mugentuner

(Sep 6th 2004, 8:44am)

by jbbnet (Aug 19th 2004, 5:11pm)

3 151

by SamIV

(Aug 29th 2004, 5:43am)

by buster99ranger (Aug 25th 2002, 7:49pm)

1 252

by micjeep1

(Aug 22nd 2004, 12:05pm)

by I am (Aug 4th 2004, 4:50pm)

1 253

by SprinklerGuy

(Aug 10th 2004, 5:57am)

by rickesco (Jul 28th 2004, 8:13am)

3 171

by aquamatic

(Jul 29th 2004, 10:36am)

by jmm1804 (Jun 20th 2004, 2:34pm)

0 86

No reply

by dan2125 (Apr 10th 2004, 2:17pm)

1 114

by RVLI

(Apr 13th 2004, 5:30pm)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)