You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by hudr0004 (Sep 12th 2011, 10:16am)

4 653

by hudr0004

(Oct 24th 2011, 8:38am)

by Neil7 (Oct 24th 2011, 5:19pm)

5 375

by Neil7

(Oct 25th 2011, 8:44pm)

by LawnJockey (Oct 29th 2011, 10:39am)

1 835

by mrfixit

(Oct 29th 2011, 1:33pm)

by mdige (Oct 31st 2011, 4:31pm)

1 685

by Wet_Boots

(Nov 1st 2011, 6:36am)

by porterville cemetery (Nov 1st 2011, 2:23pm)

1 198

by Wet_Boots

(Nov 1st 2011, 3:12pm)

by RC (Nov 6th 2011, 7:46pm)

2 253

by Wet_Boots

(Nov 7th 2011, 7:57am)

by pjansen19 (Nov 7th 2011, 4:18pm)

3 692

by mrfixit

(Nov 10th 2011, 4:23am)

by lou40 (Nov 9th 2011, 4:15pm)

3 637

by Wet_Boots

(Nov 13th 2011, 8:15am)

by Brun (Apr 29th 2008, 6:59am)

4 1,918

by hi.todd

(Nov 16th 2011, 4:49pm)

by lloydlevy (Nov 28th 2011, 1:34pm)

1 164

by Wet_Boots

(Nov 28th 2011, 3:46pm)

Show

Statistics:

456 Threads - 1,701 Posts (average 0.37 Posts per Day)