You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 188

by mrfixit

(Apr 17th 2013, 5:56pm)

by mcsinkus (Jun 4th 2010, 4:35pm)

1 188

by mrfixit

(Jun 4th 2010, 7:49pm)

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 188

by Wet_Boots

(Jun 26th 2009, 8:58am)

by ArrakeenIrrigator (Sep 14th 2007, 5:48am)

3 188

by Wet_Boots

(Sep 15th 2007, 12:31am)

by The Professor (May 26th 2005, 9:47pm)

2 187

by Jazzer K

(Sep 2nd 2005, 6:19pm)

by Sue (Aug 11th 2005, 10:47am)

4 184

by Jazzer K

(Sep 2nd 2005, 6:27pm)

by jlynnrose (Mar 16th 2004, 1:33pm)

1 184

by RVLI

(Mar 16th 2004, 2:57pm)

by m collins (Jul 5th 2012, 11:04am)

3 183

by GatorGuy

(Jul 5th 2012, 12:27pm)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 182

by Ianjanson

(Apr 10th 2013, 7:37pm)

by purdymatthew (Aug 6th 2007, 6:05am)

1 181

by jmduke7

(Aug 7th 2007, 11:20am)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)