You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 187

by mrfixit

(Apr 17th 2013, 5:56pm)

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 187

by Wet_Boots

(Jun 26th 2009, 8:58am)

by Rmiclette (May 5th 2013, 6:49am)

2 186

by Scott76

(May 5th 2013, 11:41am)

by mcsinkus (Jun 4th 2010, 4:35pm)

1 186

by mrfixit

(Jun 4th 2010, 7:49pm)

by The Professor (May 26th 2005, 9:47pm)

2 186

by Jazzer K

(Sep 2nd 2005, 6:19pm)

by jlynnrose (Mar 16th 2004, 1:33pm)

1 184

by RVLI

(Mar 16th 2004, 2:57pm)

by m collins (Jul 5th 2012, 11:04am)

3 183

by GatorGuy

(Jul 5th 2012, 12:27pm)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 182

by Ianjanson

(Apr 10th 2013, 7:37pm)

by Sue (Aug 11th 2005, 10:47am)

4 182

by Jazzer K

(Sep 2nd 2005, 6:27pm)

by jmm1804 (Jun 3rd 2004, 11:49am)

2 180

by jmm1804

(Jun 7th 2004, 12:53pm)

Show

Statistics:

418 Threads - 1,564 Posts (average 0.35 Posts per Day)