You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 284

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by chrisratz (Jun 27th 2012, 7:40pm)

4 319

by chrisratz

(Jun 29th 2012, 11:18pm)

by fwoodall (Aug 28th 2005, 6:01pm)

2 761

by squints

(Jul 31st 2011, 2:16pm)

by fmayerjr (Aug 2nd 2012, 10:47am)

1 208

by Wet_Boots

(Aug 2nd 2012, 2:16pm)

by kannan (May 18th 2011, 5:07pm)

4 1,057

by Wet_Boots

(May 27th 2012, 10:31am)

by jkd1976@yahoo.com (Mar 15th 2007, 4:11pm)

7 655

by SprinklerGuy

(Mar 17th 2007, 2:22am)

by jzb18134 (Sep 7th 2011, 3:55pm)

6 308

by CRI IRR

(Sep 13th 2011, 6:34am)

by Cherrybark (May 20th 2012, 6:22pm)

2 277

by GatorGuy

(May 21st 2012, 9:04am)

by tkbryant (Dec 26th 2005, 12:59pm)

4 1,364

by lush96

(Mar 19th 2006, 7:49pm)

by rsteffan (Aug 1st 2012, 6:14pm)

6 435

by Wet_Boots

(Aug 22nd 2012, 10:52am)

Show

Statistics:

421 Threads - 1,572 Posts (average 0.36 Posts per Day)