You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by dse (Jun 8th 2012, 5:58am)

2 320

by Wet_Boots

(Jun 8th 2012, 8:48am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 588

by ddeferra

(Jun 8th 2011, 6:29pm)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 281

by Mitchgo

(Jul 25th 2011, 11:12pm)

by zipcode (Jul 10th 2011, 5:26pm)

2 213

by Mitchgo

(Jul 11th 2011, 12:24am)

by Mac54321 (Jul 13th 2011, 10:03am)

1 635

by Wet_Boots

(Jul 13th 2011, 11:30am)

by opsec (Apr 1st 2012, 7:44pm)

2 408

by Wet_Boots

(Apr 2nd 2012, 9:08am)

by grey (Aug 24th 2012, 6:29pm)

1 395

by grey

(Aug 25th 2012, 2:19pm)

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 334

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by chrisratz (Jun 27th 2012, 7:40pm)

4 384

by chrisratz

(Jun 29th 2012, 11:18pm)

by fwoodall (Aug 28th 2005, 6:01pm)

2 830

by squints

(Jul 31st 2011, 2:16pm)

Show

Statistics:

430 Threads - 1,625 Posts (average 0.36 Posts per Day)