You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 09KR0058 (Oct 13th 2015, 6:11pm)

1 217

by 09KR0058

(Oct 13th 2015, 6:42pm)

by MichaelABQ (Sep 15th 2015, 1:11am)

1 224

by mrfixit

(Sep 15th 2015, 4:19am)

by Artie (Sep 2nd 2015, 7:27am)

1 433

by Wet_Boots

(Sep 2nd 2015, 8:10am)

by fbg (Aug 13th 2015, 4:40pm)

1 511

by Central Irrigation

(Aug 13th 2015, 6:38pm)

by Jamie (Jul 29th 2015, 6:17pm)

1 193

by mrfixit

(Jul 29th 2015, 11:48pm)

by Sebastian2015 (Jul 28th 2015, 9:27am)

1 186

by Wet_Boots

(Jul 28th 2015, 11:15am)

by bjlarson (Jul 28th 2015, 9:20am)

1 100

by Wet_Boots

(Jul 28th 2015, 10:04am)

by OldBob (Jul 23rd 2015, 7:37am)

1 140

by OldBob

(Jul 23rd 2015, 8:13pm)

by Behan (Jul 17th 2015, 1:38pm)

1 146

by mrfixit

(Jul 17th 2015, 6:45pm)

by joeywfl (Jun 15th 2015, 8:34am)

1 200

by Wet_Boots

(Jun 15th 2015, 9:02am)

Show

Statistics:

508 Threads - 1,950 Posts (average 0.37 Posts per Day)