You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by pjmckellar (Jul 27th 2013, 8:25am)

1 384

by Central Irrigation

(Jul 27th 2013, 9:42am)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 394

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by rickthedrummer101 (May 11th 2013, 2:26pm)

1 404

by Wet_Boots

(May 11th 2013, 5:08pm)

by richard1975 (Apr 28th 2013, 7:12pm)

1 377

by Scott76

(May 2nd 2013, 2:06pm)

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 421

by mrfixit

(Apr 17th 2013, 5:56pm)

by Kpierce (Apr 12th 2013, 10:36pm)

1 382

by Wet_Boots

(Apr 13th 2013, 10:46am)

by Binks (Apr 10th 2013, 1:28am)

1 362

by mrfixit

(Apr 10th 2013, 3:02am)

by Island Sprinklers (Mar 12th 2013, 10:47am)

1 678

by Wet_Boots

(Mar 12th 2013, 11:42am)

by Terri (Jan 9th 2013, 6:46am)

1 469

by Wet_Boots

(Jan 9th 2013, 11:08am)

by (Dec 25th 2012, 6:20pm)

1 551

by Wet_Boots

(Dec 26th 2012, 8:32am)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)