You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 302

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by mcsinkus (Jun 4th 2010, 4:35pm)

1 346

by mrfixit

(Jun 4th 2010, 7:49pm)

by Merv (May 1st 2010, 3:44pm)

3 420

by mrfixit

(May 31st 2010, 9:47pm)

by KSknight (Aug 17th 2009, 10:53am)

1 708

by bdbengtsson

(May 21st 2010, 5:27pm)

by Eclectic (May 17th 2010, 2:01pm)

0 207

No reply

by Don_Mousseau (May 15th 2010, 8:44am)

1 677

by mrfixit

(May 15th 2010, 1:03pm)

by stephen (May 2nd 2010, 12:11pm)

0 167

No reply

by mahplane (Apr 26th 2010, 5:49pm)

0 310

No reply

by BVISailor (Oct 31st 2009, 10:11am)

1 853

by worachj

(Oct 31st 2009, 12:47pm)

by ahersman (Sep 30th 2009, 1:37pm)

1 242

by ahersman

(Sep 30th 2009, 6:15pm)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)