You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by dkraska (Aug 29th 2009, 2:41pm)

4 572

by hi.todd

(Aug 30th 2009, 9:32pm)

by fairplay (Jan 29th 2007, 1:01pm)

9 4,008

by Wet_Boots

(Aug 17th 2009, 7:50pm)

by stillc (Jul 29th 2009, 12:36pm)

2 835

by Wet_Boots

(Aug 4th 2009, 1:08am)

by Panic1978 (Jul 17th 2009, 6:52pm)

0 560

No reply

by mharden5 (Jul 11th 2009, 12:45pm)

1 307

by hi.todd

(Jul 11th 2009, 9:27pm)

by melprint (Jul 11th 2009, 9:06am)

1 328

by mrfixit

(Jul 11th 2009, 11:59am)

by wingnut (Jul 9th 2009, 10:29pm)

1 303

by mrfixit

(Jul 10th 2009, 2:31pm)

by trapkoch (Jul 5th 2009, 10:20am)

1 378

by mrfixit

(Jul 5th 2009, 12:46pm)

by lydiaE (Jun 25th 2009, 11:39am)

1 481

by HooKooDooKu

(Jul 1st 2009, 11:31am)

by George_S (Jun 26th 2009, 7:13pm)

0 267

No reply

Show

Statistics:

476 Threads - 1,794 Posts (average 0.36 Posts per Day)