You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by AWCiesiel (Jul 13th 2012, 8:42pm)

1 603

by mrfixit

(Jul 14th 2012, 12:39am)

by Montgomeryc (Jun 13th 2012, 2:46pm)

1 604

by Wet_Boots

(Jun 13th 2012, 4:03pm)

by julieblades (Jan 7th 2006, 6:27am)

6 604

by Mudpuppy

(Oct 12th 2006, 6:03pm)

by (Jul 18th 2011, 5:26pm)

1 605

by Mitchgo

(Jul 19th 2011, 12:34am)

by Grahpack (Jun 9th 2011, 7:07pm)

1 608

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by Brassguy (Feb 26th 2012, 4:36pm)

5 609

by Brassguy

(Mar 8th 2012, 10:09pm)

by Marlene (Aug 23rd 2007, 3:11am)

4 610

by Marlene

(Aug 25th 2007, 5:42am)

by desmo907 (Aug 28th 2012, 3:54pm)

3 611

by desmo907

(Sep 4th 2012, 8:33am)

by cassian (Jul 31st 2005, 2:39pm)

4 614

by RidgeRun05

(Aug 1st 2005, 4:58pm)

by quick11 (Oct 7th 2010, 10:53am)

3 616

by Wet_Boots

(Oct 23rd 2010, 9:10am)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)