You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by quick11 (Oct 7th 2010, 10:53am)

3 563

by Wet_Boots

(Oct 23rd 2010, 9:10am)

by macminn (Jun 11th 2007, 5:43pm)

2 564

by mrfixit

(Jun 7th 2008, 8:13am)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 565

by Mitchgo

(Jul 19th 2011, 12:34am)

by Marlene (Aug 23rd 2007, 3:11am)

4 566

by Marlene

(Aug 25th 2007, 5:42am)

by Brassguy (Feb 26th 2012, 4:36pm)

5 567

by Brassguy

(Mar 8th 2012, 10:09pm)

by Metalman1 (May 23rd 2011, 11:56am)

3 568

by sharon

(May 30th 2011, 12:20pm)

by irar (Jul 11th 2011, 5:27pm)

4 571

by AutomaticSprinklers

(Jul 20th 2011, 8:49pm)

by desmo907 (Aug 28th 2012, 3:54pm)

3 572

by desmo907

(Sep 4th 2012, 8:33am)

by dkraska (Aug 29th 2009, 2:41pm)

4 575

by hi.todd

(Aug 30th 2009, 9:32pm)

by Grahpack (Jun 9th 2011, 7:07pm)

1 577

by Wet_Boots

(Jun 9th 2011, 9:05pm)

Show

Statistics:

477 Threads - 1,798 Posts (average 0.37 Posts per Day)