You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Trabecca (Mar 13th 2013, 6:22pm)

7 449

by Trabecca

(Mar 18th 2013, 8:23am)

by nrwe (Jul 19th 2012, 1:57pm)

4 452

by mrfixit

(Jul 20th 2012, 3:06pm)

by Rick Hudspeth (May 31st 2006, 5:13am)

2 452

by Rick Hudspeth

(May 31st 2006, 7:35am)

by hudr0004 (Sep 12th 2011, 10:16am)

4 453

by hudr0004

(Oct 24th 2011, 8:38am)

by BenC (Apr 10th 2007, 6:32pm)

7 453

by BenC

(Apr 17th 2007, 5:38pm)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 454

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by rsteffan (Aug 1st 2012, 6:14pm)

6 454

by Wet_Boots

(Aug 22nd 2012, 10:52am)

by tbtech24 (Jun 9th 2011, 9:24am)

3 455

by Wet_Boots

(Jun 9th 2011, 10:09am)

by EtzGx (Jun 21st 2009, 12:40pm)

0 455

No reply

by whitty (Apr 20th 2012, 8:09am)

10 457

by GatorGuy

(Apr 23rd 2012, 8:45am)

Show

Statistics:

429 Threads - 1,623 Posts (average 0.36 Posts per Day)