You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by julieblades (Jan 7th 2006, 6:27am)

6 186

by Mudpuppy

(Oct 12th 2006, 6:03pm)

by Grahpack (Jun 9th 2011, 7:07pm)

1 430

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by ruchuck (May 29th 2013, 8:54am)

7 454

by mrfixit

(Jun 2nd 2013, 12:03am)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 444

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by bzook@aol.com (Jun 8th 2006, 1:47pm)

1 179

by Wet_Boots

(Jun 8th 2006, 3:46pm)

by alabama8100 (Jun 8th 2012, 1:35pm)

6 1,549

by GatorGuy

(Jun 11th 2012, 8:38am)

by redlinr (Jun 9th 2005, 3:46am)

3 651

by Jazzer K

(Sep 2nd 2005, 6:14pm)

by njchoochoo1 (Oct 16th 2012, 8:13pm)

3 474

by Wet_Boots

(Oct 18th 2012, 9:14am)

by purdymatthew (Aug 6th 2007, 6:05am)

1 221

by jmduke7

(Aug 7th 2007, 11:20am)

by George_S (Jun 26th 2009, 7:13pm)

0 206

No reply

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)