You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by odiaz1 (May 10th 2012, 10:18am)

1 334

by Wet_Boots

(May 10th 2012, 10:26am)

by ros (Mar 15th 2012, 7:40pm)

1 351

by hi.todd

(Mar 20th 2012, 9:07pm)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 157

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by HHicks (Jul 22nd 2011, 4:57pm)

1 551

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by Lainiest (Jul 2nd 2012, 7:11pm)

2 156

by GatorGuy

(Jul 3rd 2012, 8:00am)

by tico (Jun 15th 2013, 8:58pm)

0 245

No reply

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 197

by mrfixit

(Apr 17th 2013, 5:56pm)

by mahplane (Apr 26th 2010, 5:49pm)

0 251

No reply

by jcmckinney1 (Oct 6th 2011, 10:38am)

1 127

by Wet_Boots

(Oct 6th 2011, 6:55pm)

by mulletmac (Sep 30th 2011, 7:29am)

2 335

by mulletmac

(Oct 1st 2011, 11:26am)

Show

Statistics:

421 Threads - 1,572 Posts (average 0.36 Posts per Day)