You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by crashxx (Apr 28th 2012, 12:16pm)

4 1,178

by crashxx

(May 1st 2012, 9:15am)

by fbg (Aug 13th 2015, 4:40pm)

1 460

by Central Irrigation

(Aug 13th 2015, 6:38pm)

by JimsLawn (Sep 8th 2015, 2:33pm)

0 250

No reply

by brobinson (Jun 12th 2010, 7:44am)

8 2,672

by Wet_Boots

(Mar 31st 2012, 4:43pm)

by pohall@kivexmail.com (May 13th 2006, 9:21am)

1 1,118

by jmduke7

(Aug 17th 2006, 3:13pm)

by jhkatytx (Apr 14th 2016, 5:36pm)

8 153

by jhkatytx

(Apr 23rd 2016, 3:47pm)

by JimB (Jul 30th 2011, 3:59pm)

1 300

by Wet_Boots

(Jul 30th 2011, 4:53pm)

by dwinmac (Sep 4th 2010, 2:42pm)

3 600

by Wet_Boots

(Sep 5th 2010, 2:55pm)

by wjmoore (Aug 1st 2004, 8:04am)

2 1,735

by nestors

(Oct 31st 2004, 1:30pm)

by Texas_Pete (May 1st 2005, 7:21pm)

1 536

by Wet_Boots

(May 2nd 2005, 2:02am)

Show

Statistics:

497 Threads - 1,879 Posts (average 0.36 Posts per Day)