You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by JeakeVerent (Jun 11th 2011, 8:46pm)

3 4,026

by Mitchgo

(Jun 12th 2011, 2:13pm)

by John199 (Aug 14th 2011, 3:57pm)

4 1,215

by hi.todd

(Aug 15th 2011, 7:29pm)

by crashxx (Apr 28th 2012, 12:16pm)

4 1,198

by crashxx

(May 1st 2012, 9:15am)

by fbg (Aug 13th 2015, 4:40pm)

1 474

by Central Irrigation

(Aug 13th 2015, 6:38pm)

by JimsLawn (Sep 8th 2015, 2:33pm)

0 267

No reply

by brobinson (Jun 12th 2010, 7:44am)

8 2,705

by Wet_Boots

(Mar 31st 2012, 4:43pm)

by pohall@kivexmail.com (May 13th 2006, 9:21am)

1 1,131

by jmduke7

(Aug 17th 2006, 3:13pm)

by jhkatytx (Apr 14th 2016, 5:36pm)

8 193

by jhkatytx

(Apr 23rd 2016, 3:47pm)

by JimB (Jul 30th 2011, 3:59pm)

1 304

by Wet_Boots

(Jul 30th 2011, 4:53pm)

by dwinmac (Sep 4th 2010, 2:42pm)

3 610

by Wet_Boots

(Sep 5th 2010, 2:55pm)

Show

Statistics:

500 Threads - 1,910 Posts (average 0.37 Posts per Day)