You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Metalman1 (May 23rd 2011, 11:56am)

3 399

by sharon

(May 30th 2011, 12:20pm)

by krantzr (Apr 30th 2011, 8:26am)

3 1,099

by mrfixit

(May 1st 2011, 11:34am)

by stellar495 (Mar 17th 2011, 8:57pm)

3 1,499

by hi.todd

(Mar 20th 2011, 11:03am)

by quick11 (Oct 7th 2010, 10:53am)

3 389

by Wet_Boots

(Oct 23rd 2010, 9:10am)

by dwinmac (Sep 4th 2010, 2:42pm)

3 357

by Wet_Boots

(Sep 5th 2010, 2:55pm)

by RedArt (Aug 15th 2010, 11:03am)

3 1,498

by mrfixit

(Aug 31st 2010, 2:23pm)

by guy_sparky (Aug 12th 2010, 10:35am)

3 632

by mrfixit

(Aug 12th 2010, 5:12pm)

by fragnus (Jul 25th 2010, 9:45pm)

3 1,255

by Wet_Boots

(Jul 27th 2010, 8:25pm)

by lawnnovice (Jul 5th 2010, 3:03pm)

3 1,052

by Wet_Boots

(Jul 6th 2010, 7:00pm)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 205

by HooKooDooKu

(Jun 9th 2010, 11:12am)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)