You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by HHicks (Jul 22nd 2011, 4:57pm)

1 540

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 311

by Mitchgo

(Jul 19th 2011, 12:34am)

by veidtmeister (Jul 15th 2011, 9:03pm)

1 193

by Wet_Boots

(Jul 15th 2011, 11:06pm)

by Mac54321 (Jul 13th 2011, 10:03am)

1 591

by Wet_Boots

(Jul 13th 2011, 11:30am)

by ncampbel (Jul 1st 2011, 2:15pm)

1 510

by Mitchgo

(Jul 1st 2011, 9:20pm)

by Ryanm519 (Jun 16th 2011, 1:28am)

1 335

by Wet_Boots

(Jun 16th 2011, 6:25am)

by Grahpack (Jun 9th 2011, 7:07pm)

1 353

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 252

by Mitchgo

(Jun 6th 2011, 9:34pm)

by Moggie (Jun 4th 2011, 10:48am)

1 197

by Mitchgo

(Jun 5th 2011, 1:28pm)

by blh (Jun 4th 2011, 12:55pm)

1 281

by Mitchgo

(Jun 4th 2011, 3:32pm)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)