You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by nightshark (Sep 9th 2013, 3:11pm)

3 822

by mrfixit

(Sep 9th 2013, 6:05pm)

by mydogcleo (Aug 28th 2013, 10:11am)

1 472

by Wet_Boots

(Aug 28th 2013, 1:36pm)

by Bwilson2 (Aug 13th 2013, 10:12pm)

2 584

by mrfixit

(Aug 14th 2013, 12:28pm)

by pjmckellar (Jul 27th 2013, 8:25am)

1 419

by Central Irrigation

(Jul 27th 2013, 9:42am)

by cjohnson2020 (Jul 26th 2013, 4:31pm)

2 460

by mrfixit

(Jul 27th 2013, 2:59am)

by BessMan94 (Jun 24th 2013, 8:45pm)

3 635

by mrfixit

(Jun 25th 2013, 8:32pm)

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 750

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 444

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by ruchuck (May 29th 2013, 8:54am)

7 967

by mrfixit

(Jun 2nd 2013, 12:03am)

by rickthedrummer101 (May 11th 2013, 2:26pm)

1 450

by Wet_Boots

(May 11th 2013, 5:08pm)

Show

Statistics:

500 Threads - 1,916 Posts (average 0.37 Posts per Day)