You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Towelie427 (Sep 1st 2014, 7:10pm)

4 363

by Wet_Boots

(Oct 5th 2014, 2:45pm)

by 95mmrenegade (Jul 20th 2014, 10:30am)

4 250

by Central Irrigation

(Jul 20th 2014, 2:43pm)

by LT87 (May 21st 2014, 11:33am)

3 275

by hi.todd

(May 27th 2014, 1:03pm)

by andyl (Apr 21st 2014, 8:32pm)

3 391

by Wet_Boots

(Apr 27th 2014, 9:26am)

by Gansmanms (Nov 7th 2012, 9:10pm)

7 2,205

by marian

(Sep 2nd 2013, 5:37pm)

by Freddyfrom fl (Aug 6th 2013, 6:49pm)

1 362

by Wet_Boots

(Aug 6th 2013, 9:29pm)

by sdguy (Mar 10th 2013, 3:15pm)

3 740

by Wet_Boots

(Jul 31st 2013, 10:41am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 1,036

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by Pippilo (Jul 1st 2013, 9:15pm)

3 630

by mrfixit

(Jul 2nd 2013, 3:07am)

by 7907 (May 3rd 2013, 12:55am)

2 467

by PennyInHeels

(Jun 25th 2013, 9:49am)

Show

Statistics:

500 Threads - 1,903 Posts (average 0.37 Posts per Day)