You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by LT87 (May 21st 2014, 11:33am)

3 184

by hi.todd

(May 27th 2014, 1:03pm)

by abcoker (May 9th 2014, 2:43pm)

5 340

by Wet_Boots

(May 23rd 2014, 7:04am)

by andyl (Apr 21st 2014, 8:32pm)

3 242

by Wet_Boots

(Apr 27th 2014, 9:26am)

by edwildesr (Oct 7th 2007, 7:02pm)

2 1,674

by mrfixit

(Aug 26th 2013, 8:00pm)

by sdguy (Mar 10th 2013, 3:15pm)

3 563

by Wet_Boots

(Jul 31st 2013, 10:41am)

by 7907 (May 3rd 2013, 12:55am)

2 351

by PennyInHeels

(Jun 25th 2013, 9:49am)

by tico (Jun 15th 2013, 8:58pm)

0 459

No reply

by gobris (May 14th 2013, 9:45am)

3 539

by Wet_Boots

(May 16th 2013, 8:30am)

by Rmiclette (May 5th 2013, 6:49am)

2 374

by Scott76

(May 5th 2013, 11:41am)

by Caltino (Apr 12th 2013, 7:18pm)

12 1,161

by Wet_Boots

(Apr 27th 2013, 7:42am)

Show

Statistics:

438 Threads - 1,676 Posts (average 0.35 Posts per Day)