You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by macminn (Jun 11th 2007, 5:43pm)

2 412

by mrfixit

(Jun 7th 2008, 8:13am)

by Buff (Jun 6th 2008, 8:25am)

6 3,086

by mrfixit

(Jun 6th 2008, 1:59pm)

by Wharfrat (May 16th 2008, 11:43am)

1 272

by mrfixit

(May 16th 2008, 5:43pm)

by badsprinklers (Oct 10th 2007, 4:55pm)

12 2,214

by Wet_Boots

(Apr 27th 2008, 11:09am)

by jimmyburg (Nov 19th 2007, 6:27am)

1 326

by hi.todd

(Apr 6th 2008, 5:05pm)

by Dennis (Oct 15th 2007, 7:30am)

1 579

by edwildesr

(Nov 5th 2007, 7:53am)

by crazydayz (Oct 17th 2007, 6:33am)

0 259

No reply

by sanddido (Oct 11th 2007, 3:39am)

1 300

by mrfixit

(Oct 11th 2007, 2:03pm)

by ArrakeenIrrigator (Sep 14th 2007, 5:52am)

3 747

by edwildesr

(Oct 7th 2007, 6:49pm)

by tmshead (Oct 1st 2007, 4:35am)

2 363

by Wet_Boots

(Oct 3rd 2007, 6:52am)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)