You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by jmm1804 (Jun 20th 2004, 2:34pm)

0 177

No reply

by janeandjoseph (Jul 6th 2004, 11:05pm)

2 331

by janeandjoseph

(Jul 7th 2004, 8:03pm)

by rickesco (Jul 28th 2004, 8:13am)

3 340

by aquamatic

(Jul 29th 2004, 10:36am)

by I am (Aug 4th 2004, 4:50pm)

1 411

by SprinklerGuy

(Aug 10th 2004, 5:57am)

by buster99ranger (Aug 25th 2002, 7:49pm)

1 387

by micjeep1

(Aug 22nd 2004, 12:05pm)

by jbbnet (Aug 19th 2004, 5:11pm)

3 318

by SamIV

(Aug 29th 2004, 5:43am)

by torodude (Aug 27th 2004, 12:47pm)

1 419

by SprinklerGuy

(Aug 30th 2004, 8:24am)

by mugentuner (Aug 30th 2004, 12:30pm)

1 294

by mugentuner

(Sep 6th 2004, 8:44am)

by 206007075 (Sep 28th 2004, 10:26am)

0 559

No reply

by mosida (Sep 29th 2004, 9:16am)

3 400

by nestors

(Oct 31st 2004, 1:27pm)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)