You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Reg1987 (Jul 12th 2015, 7:43pm)

3 151

by Wet_Boots

(Jul 14th 2015, 6:12pm)

by jhkatytx (Apr 14th 2016, 5:36pm)

8 152

by jhkatytx

(Apr 23rd 2016, 3:47pm)

by MichaelABQ (Sep 15th 2015, 1:11am)

1 155

by mrfixit

(Sep 15th 2015, 4:19am)

by Gilgaretch (Jun 23rd 2015, 8:23pm)

0 156

No reply

by 09KR0058 (Oct 13th 2015, 6:11pm)

1 158

by 09KR0058

(Oct 13th 2015, 6:42pm)

by Roco8823 (Jun 22nd 2015, 11:43pm)

3 160

by mrfixit

(Jun 23rd 2015, 11:44am)

by jyd (May 25th 2015, 4:37am)

1 160

by Wet_Boots

(May 25th 2015, 8:12am)

by PabloCruise (May 3rd 2015, 4:28pm)

3 160

by Wet_Boots

(May 4th 2015, 11:53am)

by Jamie (Jul 29th 2015, 6:17pm)

1 170

by mrfixit

(Jul 29th 2015, 11:48pm)

by Sebastian2015 (Jul 28th 2015, 9:27am)

1 174

by Wet_Boots

(Jul 28th 2015, 11:15am)

Show

Statistics:

496 Threads - 1,876 Posts (average 0.36 Posts per Day)