You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Sebastian2015 (Jul 28th 2015, 9:27am)

1 123

by Wet_Boots

(Jul 28th 2015, 11:15am)

by Eowilcox (Jun 18th 2015, 12:20pm)

2 123

by Eowilcox

(Jun 18th 2015, 2:23pm)

by EricJRW (May 6th 2015, 8:09pm)

2 125

by EricJRW

(May 7th 2015, 7:04am)

by ddunkley (Jun 8th 2015, 3:57pm)

1 131

by Wet_Boots

(Jun 8th 2015, 4:58pm)

by ScorpioTravis (Aug 10th 2015, 1:06pm)

0 134

No reply

by 6pack (May 13th 2015, 8:14pm)

1 148

by Wet_Boots

(May 13th 2015, 8:54pm)

by CRASH (Aug 6th 2015, 6:02pm)

3 152

by Wet boots

(Aug 7th 2015, 3:30pm)

by Artie (Sep 2nd 2015, 7:27am)

1 155

by Wet_Boots

(Sep 2nd 2015, 8:10am)

by trs (Aug 4th 2015, 7:38pm)

2 155

by Evergreen Sprinkler

(Aug 7th 2015, 1:34pm)

by zsac09 (Jun 8th 2015, 2:57pm)

2 159

by zsac09

(Jun 10th 2015, 3:26pm)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)