You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by donlo (Apr 18th 2006, 3:20am)

0 106

No reply

by Fisher (Aug 7th 2010, 5:43pm)

0 107

No reply

by 68watford (Apr 30th 2006, 9:14am)

0 107

No reply

by Mindy (Aug 23rd 2011, 12:33pm)

1 109

by Wet_Boots

(Aug 23rd 2011, 2:30pm)

by JimB (Jul 30th 2011, 3:59pm)

1 111

by Wet_Boots

(Jul 30th 2011, 4:53pm)

by gregson (Jul 22nd 2006, 10:14am)

2 113

by nestors

(Aug 2nd 2006, 6:26pm)

by porterville cemetery (Nov 1st 2011, 2:23pm)

1 114

by Wet_Boots

(Nov 1st 2011, 3:12pm)

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 117

by mrfixit

(Oct 16th 2011, 2:26am)

by evergreenz (Sep 3rd 2011, 2:33am)

2 117

by evergreenz

(Sep 3rd 2011, 12:08pm)

by SpritzCan (Apr 21st 2012, 8:33pm)

2 119

by GatorGuy

(Apr 23rd 2012, 8:47am)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)