You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by zenavttmn (Apr 22nd 2006, 9:25am)

5 852

by zenavttmn

(Apr 24th 2006, 1:21pm)

by Gremlin274 (Jun 12th 2005, 12:57pm)

1 268

by Wet_Boots

(Jun 12th 2005, 1:13pm)

by jimmyburg (Oct 2nd 2007, 7:22am)

0 359

No reply

by richard1975 (Apr 28th 2013, 7:12pm)

1 332

by Scott76

(May 2nd 2013, 2:06pm)

by peterheading (Oct 25th 2005, 5:03pm)

2 300

by Wet_Boots

(Oct 27th 2005, 2:43am)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 470

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by betsycam (Oct 13th 2013, 4:26pm)

1 814

by Wet_Boots

(Oct 14th 2013, 10:18am)

by dzuroff (Oct 13th 2003, 7:33am)

3 393

by bhungue2

(Oct 15th 2003, 8:06am)

by Evergreen Sprinkler (Aug 4th 2015, 5:43pm)

0 66

No reply

by Mitchell (Feb 27th 2011, 2:26pm)

1 489

by hi.todd

(Feb 27th 2011, 4:12pm)

Show

Statistics:

474 Threads - 1,781 Posts (average 0.36 Posts per Day)