You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 13dwf (Sep 7th 2010, 1:03pm)

4 689

by Wet_Boots

(Sep 9th 2010, 8:50pm)

by LX2 (Jul 16th 2015, 3:14pm)

2 141

by LX2

(Jul 17th 2015, 8:27am)

by john_00 (Jan 16th 2016, 1:53pm)

7 146

by Wet_Boots

(Jan 19th 2016, 9:09am)

by pjmckellar (Jul 27th 2013, 8:25am)

1 409

by Central Irrigation

(Jul 27th 2013, 9:42am)

by 09KR0058 (Oct 13th 2015, 6:11pm)

1 157

by 09KR0058

(Oct 13th 2015, 6:42pm)

by slemani62 (Jul 29th 2010, 2:56pm)

1 906

by mrfixit

(Jul 29th 2010, 6:35pm)

by gregson (Jul 22nd 2006, 10:14am)

2 325

by nestors

(Aug 2nd 2006, 6:26pm)

by Benmt (Jul 25th 2014, 8:34pm)

1 239

by Wet_Boots

(Jul 26th 2014, 6:30am)

by gerald (May 31st 2006, 5:44am)

2 357

by jmduke7

(Aug 17th 2006, 3:03pm)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 534

by Ianjanson

(Apr 10th 2013, 7:37pm)

Show

Statistics:

496 Threads - 1,876 Posts (average 0.36 Posts per Day)