You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by LX2 (Jul 16th 2015, 3:14pm)

2 57

by LX2

(Jul 17th 2015, 8:27am)

by pjmckellar (Jul 27th 2013, 8:25am)

1 336

by Central Irrigation

(Jul 27th 2013, 9:42am)

by slemani62 (Jul 29th 2010, 2:56pm)

1 789

by mrfixit

(Jul 29th 2010, 6:35pm)

by gregson (Jul 22nd 2006, 10:14am)

2 254

by nestors

(Aug 2nd 2006, 6:26pm)

by Benmt (Jul 25th 2014, 8:34pm)

1 172

by Wet_Boots

(Jul 26th 2014, 6:30am)

by gerald (May 31st 2006, 5:44am)

2 271

by jmduke7

(Aug 17th 2006, 3:03pm)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 429

by Ianjanson

(Apr 10th 2013, 7:37pm)

by Rendaug (Jan 18th 2004, 12:31pm)

3 338

by Rendaug

(Feb 8th 2004, 10:37am)

by Drski (Jul 29th 2011, 11:50am)

5 757

by Drski

(Aug 9th 2011, 11:04am)

by Tee Jay (May 17th 2007, 8:38am)

3 311

by Bill Painter

(May 21st 2007, 1:12pm)

Show

Statistics:

465 Threads - 1,754 Posts (average 0.36 Posts per Day)