You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Brie (Feb 24th 2009, 11:42am)

2 502

by sanzen96

(Mar 21st 2009, 3:55pm)

by rcajun36 (Jun 26th 2006, 5:13am)

3 1,069

by xpedient

(Jun 26th 2006, 6:53am)

by archiejobs (May 31st 2006, 4:18am)

2 192

by archiejobs

(May 31st 2006, 4:24am)

by Chuck (Jun 29th 2003, 2:59pm)

3 278

by Rays Sprinklers

(Jul 1st 2003, 12:19pm)

by Oscar S. Ramirez (Mar 21st 2014, 5:28pm)

1 35

by mrfixit

(Mar 22nd 2014, 1:58am)

by PerryNZ (Mar 12th 2014, 10:57pm)

5 39

by PerryNZ

(Mar 14th 2014, 12:16am)

by WS-1 (May 9th 2010, 4:29pm)

26 6,596

by onkio

(Mar 12th 2014, 2:49pm)

by JT (Mar 9th 2014, 8:08pm)

1 38

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by beachdoc (May 19th 2012, 1:37pm)

5 673

by pavelow

(Oct 30th 2013, 9:51pm)

by betsycam (Oct 13th 2013, 4:26pm)

1 159

by Wet_Boots

(Oct 14th 2013, 10:18am)

Show

Statistics:

418 Threads - 1,564 Posts (average 0.35 Posts per Day)