You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Gansmanms (Nov 7th 2012, 9:10pm)

7 1,126

by marian

(Sep 2nd 2013, 5:37pm)

by mydogcleo (Aug 28th 2013, 10:11am)

1 220

by Wet_Boots

(Aug 28th 2013, 1:36pm)

by Bwilson2 (Aug 13th 2013, 10:12pm)

2 264

by mrfixit

(Aug 14th 2013, 12:28pm)

by Freddyfrom fl (Aug 6th 2013, 6:49pm)

1 185

by Wet_Boots

(Aug 6th 2013, 9:29pm)

by sdguy (Mar 10th 2013, 3:15pm)

3 356

by Wet_Boots

(Jul 31st 2013, 10:41am)

by pjmckellar (Jul 27th 2013, 8:25am)

1 196

by Central Irrigation

(Jul 27th 2013, 9:42am)

by cjohnson2020 (Jul 26th 2013, 4:31pm)

2 188

by mrfixit

(Jul 27th 2013, 2:59am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 453

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by Pippilo (Jul 1st 2013, 9:15pm)

3 266

by mrfixit

(Jul 2nd 2013, 3:07am)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 363

by electrifiedmale

(Jun 30th 2013, 7:14pm)

Show

Statistics:

429 Threads - 1,623 Posts (average 0.36 Posts per Day)