You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 09KR0058 (Oct 13th 2015, 6:11pm)

1 199

by 09KR0058

(Oct 13th 2015, 6:42pm)

by MichaelABQ (Sep 15th 2015, 1:11am)

1 197

by mrfixit

(Sep 15th 2015, 4:19am)

by Dagobah (Sep 3rd 2015, 3:46pm)

3 745

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

by 88goldwing (Sep 1st 2015, 2:28pm)

12 730

by 88goldwing

(Sep 8th 2015, 5:36pm)

by JimsLawn (Sep 8th 2015, 2:33pm)

0 268

No reply

by PAP (Aug 19th 2015, 10:04am)

2 597

by PAP

(Sep 8th 2015, 9:57am)

by Artie (Sep 2nd 2015, 7:27am)

1 401

by Wet_Boots

(Sep 2nd 2015, 8:10am)

by GT6812 (Aug 28th 2015, 8:40am)

2 398

by GT6812

(Aug 31st 2015, 11:15am)

by fbg (Aug 13th 2015, 4:40pm)

1 476

by Central Irrigation

(Aug 13th 2015, 6:38pm)

by denver9 (Aug 10th 2015, 10:47pm)

3 416

by Wet_Boots

(Aug 12th 2015, 3:44am)

Show

Statistics:

500 Threads - 1,915 Posts (average 0.37 Posts per Day)