You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by beanpole (Aug 21st 2010, 10:20pm)

5 1,049

by Wet_Boots

(Aug 24th 2010, 12:57pm)

by BRL (Jun 13th 2007, 2:03pm)

0 1,627

No reply

by Brun (Apr 29th 2008, 6:59am)

4 2,199

by hi.todd

(Nov 16th 2011, 4:49pm)

by jackh (Jun 12th 2011, 11:57am)

9 3,325

by Wet_Boots

(Jun 13th 2011, 9:17am)

by wjmoore (Aug 1st 2004, 8:04am)

2 1,572

by nestors

(Oct 31st 2004, 1:30pm)

by WS-1 (May 9th 2010, 4:29pm)

28 10,083

by Romeo

(Jun 10th 2014, 3:57am)

by bluetractormanc (Aug 9th 2011, 10:59pm)

1 801

by Wet_Boots

(Aug 10th 2011, 7:51am)

by lawnnovice (Jul 5th 2010, 3:03pm)

3 1,235

by Wet_Boots

(Jul 6th 2010, 7:00pm)

by BenC (Apr 10th 2007, 6:32pm)

7 668

by BenC

(Apr 17th 2007, 5:38pm)

by Fapp (Feb 21st 2005, 10:11am)

3 743

by nestors

(Apr 7th 2005, 8:51am)

Show

Statistics:

471 Threads - 1,753 Posts (average 0.36 Posts per Day)