You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by AZHomeOwner (May 7th 2011, 1:35pm)

1 574

by Mitchgo

(May 9th 2011, 1:04am)

by waboehly (May 1st 2007, 6:51am)

1 573

by Tom

(May 1st 2007, 3:34pm)

by Smithwilde (Aug 1st 2011, 1:23pm)

5 572

by Smithwilde

(Aug 1st 2011, 8:37pm)

by bobottolini (Jul 10th 2006, 12:27pm)

3 572

by jmduke7

(Aug 16th 2006, 6:30pm)

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 565

by mrfixit

(Apr 17th 2013, 5:56pm)

by Terri (Jan 9th 2013, 6:46am)

1 565

by Wet_Boots

(Jan 9th 2013, 11:08am)

by TheEngineer (Sep 14th 2005, 5:44pm)

4 561

by lush96

(Mar 19th 2006, 8:13pm)

by handan (Nov 30th 2011, 11:30pm)

2 556

by handan

(Dec 2nd 2011, 4:56am)

by cjohnson2020 (Jul 26th 2013, 4:31pm)

2 555

by mrfixit

(Jul 27th 2013, 2:59am)

by mcsinkus (Jun 4th 2010, 4:35pm)

1 548

by mrfixit

(Jun 4th 2010, 7:49pm)

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)