You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mcsinkus (Jun 4th 2010, 4:35pm)

1 388

by mrfixit

(Jun 4th 2010, 7:49pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 387

by Mitchgo

(Jun 6th 2011, 9:34pm)

by mydogcleo (Aug 28th 2013, 10:11am)

1 386

by Wet_Boots

(Aug 28th 2013, 1:36pm)

by TheEngineer (Sep 14th 2005, 5:44pm)

4 385

by lush96

(Mar 19th 2006, 8:13pm)

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 380

by mrfixit

(Apr 17th 2013, 5:56pm)

by bcampy1 (Jun 15th 2007, 11:06am)

0 380

No reply

by archiejobs (May 31st 2006, 4:18am)

2 380

by archiejobs

(May 31st 2006, 4:24am)

by william62949 (Oct 10th 2010, 2:56pm)

1 379

by mrfixit

(Oct 10th 2010, 6:02pm)

by veidtmeister (Jul 15th 2011, 9:03pm)

1 378

by Wet_Boots

(Jul 15th 2011, 11:06pm)

by cjohnson2020 (Jul 26th 2013, 4:31pm)

2 377

by mrfixit

(Jul 27th 2013, 2:59am)

Show

Statistics:

474 Threads - 1,780 Posts (average 0.36 Posts per Day)