You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by tbtech24 (Jun 9th 2011, 9:24am)

3 912

by Wet_Boots

(Jun 9th 2011, 10:09am)

by dsmayse (Oct 24th 2015, 10:43am)

3 811

by Wet_Boots

(Oct 25th 2015, 5:55pm)

by ASV (May 11th 2015, 6:30am)

1 339

by Wet_Boots

(May 11th 2015, 8:09am)

by Marvel (Jan 19th 2013, 6:54am)

7 1,649

by Marvel

(Jan 22nd 2013, 7:49pm)

by slugbugblue (Jul 16th 2010, 6:40am)

2 403

by Wet_Boots

(Jul 17th 2010, 9:11am)

by MJ (Jul 8th 2007, 5:23am)

0 219

No reply

by jimmyburg (Nov 19th 2007, 6:27am)

1 546

by hi.todd

(Apr 6th 2008, 5:05pm)

by Moggie (Jun 4th 2011, 10:48am)

1 412

by Mitchgo

(Jun 5th 2011, 1:28pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 361

by Wet_Boots

(Jun 19th 2006, 6:17am)

by boba (Jul 25th 2005, 7:26am)

0 253

No reply

Show

Statistics:

505 Threads - 1,935 Posts (average 0.37 Posts per Day)