You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by jeffg (Oct 22nd 2011, 6:06pm)

1 341

by Wet_Boots

(Oct 23rd 2011, 11:52am)

by RT (Oct 12th 2011, 8:10pm)

1 448

by mrfixit

(Oct 12th 2011, 11:29pm)

by jcmckinney1 (Oct 6th 2011, 10:38am)

1 127

by Wet_Boots

(Oct 6th 2011, 6:55pm)

by danny1949 (Sep 22nd 2011, 12:04pm)

1 184

by Wet_Boots

(Sep 22nd 2011, 5:05pm)

by maddog (Sep 8th 2011, 5:48pm)

1 154

by grey

(Sep 9th 2011, 11:40am)

by lbfalgi (Aug 30th 2011, 6:15pm)

1 735

by Central Irrigation

(Aug 30th 2011, 8:38pm)

by Mindy (Aug 23rd 2011, 12:33pm)

1 110

by Wet_Boots

(Aug 23rd 2011, 2:30pm)

by bluetractormanc (Aug 9th 2011, 10:59pm)

1 488

by Wet_Boots

(Aug 10th 2011, 7:51am)

by clm716 (Aug 7th 2011, 9:58am)

1 149

by Central Irrigation

(Aug 7th 2011, 10:49am)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 125

by Wet_Boots

(Aug 4th 2011, 9:27pm)

Show

Statistics:

421 Threads - 1,572 Posts (average 0.36 Posts per Day)