You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by AWCiesiel (Jul 13th 2012, 8:42pm)

1 412

by mrfixit

(Jul 14th 2012, 12:39am)

by modetz (Jun 16th 2012, 11:23am)

1 267

by Wet_Boots

(Jun 16th 2012, 12:29pm)

by Montgomeryc (Jun 13th 2012, 2:46pm)

1 432

by Wet_Boots

(Jun 13th 2012, 4:03pm)

by 0303maz (Jun 12th 2012, 9:20am)

1 206

by mrfixit

(Jun 12th 2012, 9:45am)

by harrisst14 (Jun 10th 2012, 6:29pm)

1 719

by mrfixit

(Jun 10th 2012, 8:13pm)

by kenttab (May 21st 2012, 5:51pm)

1 764

by mrfixit

(May 21st 2012, 8:58pm)

by odiaz1 (May 10th 2012, 10:18am)

1 393

by Wet_Boots

(May 10th 2012, 10:26am)

by jack z (Apr 8th 2012, 10:35am)

1 446

by mrfixit

(Apr 8th 2012, 2:37pm)

by ros (Mar 15th 2012, 7:40pm)

1 435

by hi.todd

(Mar 20th 2012, 9:07pm)

by Jonas_ (Mar 14th 2012, 6:16am)

1 396

by GatorGuy

(Mar 14th 2012, 7:35am)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)