You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ianmac (Apr 25th 2011, 10:45pm)

1 649

by Wet_Boots

(Apr 26th 2011, 9:20am)

by jchsmiller (Apr 18th 2011, 11:47am)

1 310

by Wet_Boots

(Apr 20th 2011, 12:27pm)

by g (Apr 19th 2011, 1:56pm)

0 204

No reply

by orgits (Apr 9th 2011, 5:10pm)

2 680

by Mitchgo

(Apr 10th 2011, 2:29am)

by denm31 (Apr 4th 2011, 3:11pm)

6 559

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by joe decoste (Mar 19th 2011, 11:56am)

1 214

by Wet_Boots

(Mar 20th 2011, 7:29am)

by Mitchell (Feb 27th 2011, 2:26pm)

1 396

by hi.todd

(Feb 27th 2011, 4:12pm)

by Fidalgorob (Dec 4th 2010, 12:19pm)

1 431

by mrfixit

(Dec 4th 2010, 1:48pm)

by william62949 (Oct 10th 2010, 2:56pm)

1 315

by mrfixit

(Oct 10th 2010, 6:02pm)

by shellbeach (Sep 27th 2010, 4:18pm)

2 236

by Wet_Boots

(Sep 28th 2010, 1:11pm)

Show

Statistics:

457 Threads - 1,702 Posts (average 0.37 Posts per Day)