You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by horse_98 (Aug 22nd 2011, 4:03pm)

2 124

by Wet_Boots

(Aug 23rd 2011, 11:43am)

by Mindy (Aug 23rd 2011, 12:33pm)

1 125

by Wet_Boots

(Aug 23rd 2011, 2:30pm)

by lbfalgi (Aug 30th 2011, 6:15pm)

1 897

by Central Irrigation

(Aug 30th 2011, 8:38pm)

by chrisrlewis78 (Aug 4th 2011, 6:51pm)

18 1,799

by chrisrlewis78

(Aug 31st 2011, 4:50pm)

by evergreenz (Sep 3rd 2011, 2:33am)

2 147

by evergreenz

(Sep 3rd 2011, 12:08pm)

by Jimy (Aug 30th 2011, 11:45am)

4 493

by chrisrlewis78

(Sep 4th 2011, 2:52pm)

by hockeyist77 (Sep 1st 2011, 6:21pm)

4 808

by hockeyist77

(Sep 7th 2011, 3:47pm)

by maddog (Sep 8th 2011, 5:48pm)

1 174

by grey

(Sep 9th 2011, 11:40am)

by tbatrof (Sep 10th 2011, 7:00pm)

2 232

by mrfixit

(Sep 10th 2011, 10:07pm)

by jzb18134 (Sep 7th 2011, 3:55pm)

6 369

by CRI IRR

(Sep 13th 2011, 6:34am)

Show

Statistics:

431 Threads - 1,630 Posts (average 0.36 Posts per Day)