You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 538

by Mitchgo

(Jul 19th 2011, 12:34am)

by macminn (Jun 11th 2007, 5:43pm)

2 538

by mrfixit

(Jun 7th 2008, 8:13am)

by Marlene (Aug 23rd 2007, 3:11am)

4 539

by Marlene

(Aug 25th 2007, 5:42am)

by quick11 (Oct 7th 2010, 10:53am)

3 541

by Wet_Boots

(Oct 23rd 2010, 9:10am)

by Metalman1 (May 23rd 2011, 11:56am)

3 542

by sharon

(May 30th 2011, 12:20pm)

by EtzGx (Jun 21st 2009, 12:40pm)

0 543

No reply

by OscarNav (Apr 17th 2005, 8:54pm)

2 543

by Jazzer K

(Sep 2nd 2005, 6:15pm)

by Chuck (Jun 29th 2003, 2:59pm)

3 543

by Rays Sprinklers

(Jul 1st 2003, 12:19pm)

by paul b (Jul 3rd 2010, 10:24am)

1 545

by Wet_Boots

(Jul 6th 2010, 9:21am)

by Brassguy (Feb 26th 2012, 4:36pm)

5 548

by Brassguy

(Mar 8th 2012, 10:09pm)

Show

Statistics:

458 Threads - 1,728 Posts (average 0.36 Posts per Day)