You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by chrisratz (Jun 27th 2012, 7:40pm)

4 431

by chrisratz

(Jun 29th 2012, 11:18pm)

by Grahpack (Jun 9th 2011, 7:07pm)

1 432

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by betsycam (Oct 13th 2013, 4:26pm)

1 434

by Wet_Boots

(Oct 14th 2013, 10:18am)

by 13dwf (Sep 7th 2010, 1:03pm)

4 438

by Wet_Boots

(Sep 9th 2010, 8:50pm)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 447

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by opsec (Apr 1st 2012, 7:44pm)

2 448

by Wet_Boots

(Apr 2nd 2012, 9:08am)

by jwdawgs (Feb 26th 2007, 4:10pm)

11 448

by Tom

(Feb 28th 2007, 12:48pm)

by ssherrid (Jul 21st 2010, 12:18am)

0 452

No reply

by ddak32@yahoo.com (Oct 17th 2012, 3:09pm)

1 455

by Wet_Boots

(Oct 17th 2012, 5:31pm)

by ruchuck (May 29th 2013, 8:54am)

7 458

by mrfixit

(Jun 2nd 2013, 12:03am)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)