You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by PerryNZ (Mar 12th 2014, 10:57pm)

5 585

by PerryNZ

(Mar 14th 2014, 12:16am)

by stktrader (May 20th 2012, 5:55pm)

4 588

by Wet_Boots

(May 21st 2012, 7:02am)

by trs (Aug 4th 2015, 7:38pm)

2 590

by Evergreen Sprinkler

(Aug 7th 2015, 1:34pm)

by zipcode (Jul 10th 2011, 5:26pm)

2 593

by Mitchgo

(Jul 11th 2011, 12:24am)

by lschwart (May 2nd 2006, 3:53am)

3 593

by kevin burklund

(May 10th 2006, 12:18pm)

by PAP (Aug 19th 2015, 10:04am)

2 597

by PAP

(Sep 8th 2015, 9:57am)

by joe13 (Aug 19th 2012, 12:36pm)

1 598

by Wet_Boots

(Aug 19th 2012, 2:35pm)

by mulletmac (Sep 30th 2011, 7:29am)

2 598

by mulletmac

(Oct 1st 2011, 11:26am)

by ros (Mar 15th 2012, 7:40pm)

1 604

by hi.todd

(Mar 20th 2012, 9:07pm)

by bdt (Oct 17th 2011, 9:50am)

2 604

by Mitchgo

(Oct 17th 2011, 12:59pm)

Show

Statistics:

500 Threads - 1,915 Posts (average 0.37 Posts per Day)