You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Pippilo (Jul 1st 2013, 9:15pm)

3 326

by mrfixit

(Jul 2nd 2013, 3:07am)

by BessMan94 (Jun 24th 2013, 8:45pm)

3 291

by mrfixit

(Jun 25th 2013, 8:32pm)

by gobris (May 14th 2013, 9:45am)

3 391

by Wet_Boots

(May 16th 2013, 8:30am)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 274

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by dgaines (Nov 5th 2012, 5:27pm)

3 742

by dgaines

(Nov 10th 2012, 4:15pm)

by Jlivengood (Oct 20th 2012, 2:01am)

3 517

by Wet_Boots

(Oct 20th 2012, 5:11pm)

by njchoochoo1 (Oct 16th 2012, 8:13pm)

3 473

by Wet_Boots

(Oct 18th 2012, 9:14am)

by desmo907 (Aug 28th 2012, 3:54pm)

3 414

by desmo907

(Sep 4th 2012, 8:33am)

by m collins (Jul 5th 2012, 11:04am)

3 232

by GatorGuy

(Jul 5th 2012, 12:27pm)

by planersedge (Jun 20th 2012, 2:32pm)

3 246

by planersedge

(Jun 25th 2012, 7:27am)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)