You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by GT6812 (Yesterday, 8:40am)

1 27

by Wet_Boots

(Yesterday, 2:26pm)

by PAP (Aug 19th 2015, 10:04am)

1 141

by Wet_Boots

(Aug 19th 2015, 12:15pm)

by fbg (Aug 13th 2015, 4:40pm)

1 126

by Central Irrigation

(Aug 13th 2015, 6:38pm)

by Jamie (Jul 29th 2015, 6:17pm)

1 80

by mrfixit

(Jul 29th 2015, 11:48pm)

by Sebastian2015 (Jul 28th 2015, 9:27am)

1 99

by Wet_Boots

(Jul 28th 2015, 11:15am)

by bjlarson (Jul 28th 2015, 9:20am)

1 28

by Wet_Boots

(Jul 28th 2015, 10:04am)

by OldBob (Jul 23rd 2015, 7:37am)

1 64

by OldBob

(Jul 23rd 2015, 8:13pm)

by Behan (Jul 17th 2015, 1:38pm)

1 79

by mrfixit

(Jul 17th 2015, 6:45pm)

by joeywfl (Jun 15th 2015, 8:34am)

1 93

by Wet_Boots

(Jun 15th 2015, 9:02am)

by ddunkley (Jun 8th 2015, 3:57pm)

1 108

by Wet_Boots

(Jun 8th 2015, 4:58pm)

Show

Statistics:

474 Threads - 1,780 Posts (average 0.36 Posts per Day)