You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by zipcode (Jul 10th 2011, 5:26pm)

2 202

by Mitchgo

(Jul 11th 2011, 12:24am)

by jrb (Jul 5th 2011, 7:11pm)

2 880

by hi.todd

(Jul 12th 2011, 6:46pm)

by Mac54321 (Jul 13th 2011, 10:03am)

1 599

by Wet_Boots

(Jul 13th 2011, 11:30am)

by veidtmeister (Jul 15th 2011, 9:03pm)

1 201

by Wet_Boots

(Jul 15th 2011, 11:06pm)

by DAVID LP (Jul 18th 2011, 10:55am)

2 322

by Wet_Boots

(Jul 18th 2011, 12:19pm)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 323

by Mitchgo

(Jul 19th 2011, 12:34am)

by irar (Jul 11th 2011, 5:27pm)

4 300

by AutomaticSprinklers

(Jul 20th 2011, 8:49pm)

by HHicks (Jul 22nd 2011, 4:57pm)

1 551

by Wet_Boots

(Jul 22nd 2011, 6:38pm)

by mijd (Jul 20th 2011, 2:56pm)

2 298

by Mitchgo

(Jul 23rd 2011, 3:45am)

by GeorgeBorge21 (Jul 25th 2011, 1:15pm)

2 266

by Mitchgo

(Jul 25th 2011, 11:12pm)

Show

Statistics:

421 Threads - 1,572 Posts (average 0.36 Posts per Day)