You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by jeffg (Oct 22nd 2011, 6:06pm)

1 594

by Wet_Boots

(Oct 23rd 2011, 11:52am)

by mijd (Jul 20th 2011, 2:56pm)

2 590

by Mitchgo

(Jul 23rd 2011, 3:45am)

by blh (Jun 4th 2011, 12:55pm)

1 590

by Mitchgo

(Jun 4th 2011, 3:32pm)

by tmshead (Oct 1st 2007, 4:35am)

2 590

by Wet_Boots

(Oct 3rd 2007, 6:52am)

by kazemi (Sep 5th 2005, 11:57am)

3 589

by Wet_Boots

(Sep 5th 2005, 2:14pm)

by rrsteve (Aug 22nd 2002, 9:53pm)

1 589

by Rays Sprinklers

(May 22nd 2003, 4:13am)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 587

by xpedient

(Jul 2nd 2006, 3:34pm)

by ohiorebel (Apr 10th 2011, 8:59am)

2 585

by Wet_Boots

(Apr 10th 2011, 4:14pm)

by Texas_Pete (May 1st 2005, 7:21pm)

1 585

by Wet_Boots

(May 2nd 2005, 2:02am)

by Cherrybark (May 20th 2012, 6:22pm)

2 583

by GatorGuy

(May 21st 2012, 9:04am)

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)